Canonical Atlas record

TS 31.111

Universal Subscriber Identity Module (USIM) Application Toolkit (USAT)

Responsible WGC6
StatusUnder change control
Initial releaseRel-4
Selected releaseRel-18
Latest indexed version19.4.0
Series31
TypeTS

Release evolution

Compare evidence between releases

Use indexed version, Work Item and Change Request evidence to see what changed around this specification. This is an evidence trail, not a clause-by-clause normative diff.

Release ledger

Version · WI · CR evidence by release

Rel-44.17.03 WI54 CRs · 52 approved
Rel-55.12.021 WI25 CRs · 22 approved
Rel-66.15.07 WI64 CRs · 48 approved
Rel-77.17.04 WI54 CRs · 31 approved
Rel-88.15.07 WI60 CRs · 34 approved
Rel-99.12.21 WI58 CRs · 25 approved
Rel-1010.17.08 WI94 CRs · 43 approved
Rel-1111.14.03 WI77 CRs · 36 approved
Rel-1212.12.04 WI89 CRs · 36 approved
Rel-1313.8.02 WI55 CRs · 17 approved
Rel-1414.8.01 WI53 CRs · 20 approved
Rel-1515.13.01 WI129 CRs · 41 approved
Rel-1616.11.01 WI50 CRs · 23 approved
Rel-1717.14.08 WI90 CRs · 39 approved
Rel-1818.12.01 WI100 CRs · 44 approved
Rel-1919.4.01 WI44 CRs · 17 approved
Rel-20no version indexed2 WI3 CRs
R99no version indexed5 WI43 CRs · 43 approved
Release 19993.14.00 WI0 CRs

Rel-18 snapshot

Work affecting this release

100 indexed Change Requests · 1 connected Work Item.

Showing 10 CR records from the available cross-release sample. Browse release CR records (JSON) →

CR 0884 rev.1 — Updates to the CSG ID list tag in Clause 9.3 - R18

CR 0886 rev.1 — Clarify slice information for device operating in 5GS - Rel 18

CR 0881 rev.2 — Addition of a note in clause 8.148 CAG information list related to CAG ID encoding and usage.

CR 0874 — Update definition of Served S-NSSAI - Rel 18

CR 0869 — Removal of Location status Editor's Note

CR 0866 — Addition of Satellite E-UTRAN in clause 8.73 - R18

CR 0863 — Removal of redundant text in clause 8.99 - R18

CR 0860 — Update E-UTRAN Tracking Area Identification (TAI) list Identifier tag and NG-RAN Tracking Area Identification (TAI) list Identifier tag in clause 9.3 - R18

CR 0857 rev.1 — Clarifying PLI rejected slice(s) for device operating while in 5GS - Rel 18

CR 0845 rev.2 — Clarify TR handling when both mapping and not mapping S-NSSAI data objects are unavailable - Rel 18

Version history

Indexed versions

Showing 60 of 244 indexed versions.

19.4.0Rel-19CT#1122026-06-29
18.12.0Rel-18CT#1122026-06-29
19.3.0Rel-19CT#1092025-09-28
18.11.0Rel-18CT#1092025-09-28
19.2.0Rel-19CT#1082025-06-13
18.10.0Rel-18CT#1082025-06-13
17.14.0Rel-17CT#1082025-06-13
16.11.0Rel-16CT#1082025-06-13
19.1.0Rel-19CT#1072025-03-27
18.9.0Rel-18CT#1072025-03-27
17.13.0Rel-17CT#1072025-03-27
16.10.0Rel-16CT#1072025-03-27
19.0.0Rel-19CT#1062025-01-03
18.8.0Rel-18CT#1062025-01-03
18.7.0Rel-18CT#1052024-10-02
17.12.0Rel-17CT#1052024-10-02
18.6.0Rel-18CT#1042024-06-28
17.11.0Rel-17CT#1042024-06-28
18.5.1Rel-18CT#1032024-04-23
18.5.0Rel-18CT#1032024-04-10
17.10.0Rel-17CT#1032024-04-10
16.9.0Rel-16CT#1032024-04-10
18.4.1Rel-18CT#1022024-01-30
18.4.0Rel-18CT#1022024-01-10
17.9.0Rel-17CT#1022024-01-10
18.3.0Rel-18CT#1012023-09-22
17.8.0Rel-17CT#1012023-09-22
18.2.0Rel-18CT#1002023-06-26
17.7.0Rel-17CT#1002023-06-26
18.1.0Rel-18CT#992023-03-29
16.8.0Rel-16CT#992023-03-29
15.13.0Rel-15CT#992023-03-29
18.0.0Rel-18CT#98-e2022-12-15
17.6.0Rel-17CT#98-e2022-12-15
16.7.0Rel-16CT#98-e2022-12-15
15.12.0Rel-15CT#98-e2022-12-15
17.5.0Rel-17CT#97-e2022-09-23
17.4.0Rel-17CT#962022-06-24
17.3.0Rel-17CT#95-e2022-05-10
16.6.0Rel-16CT#95-e2022-04-01
17.2.0Rel-17CT#94-e2021-12-16
16.5.0Rel-16CT#94-e2021-12-16
17.1.0Rel-17CT#93-e2021-09-24
16.4.0Rel-16CT#91-e2021-04-06
15.11.0Rel-15CT#91-e2021-04-06
17.0.0Rel-17CT#90-e2020-12-11
16.3.0Rel-16CT#90-e2020-12-11
16.2.0Rel-16CT#89-e2020-09-23
15.10.0Rel-15CT#89-e2020-09-23
16.1.0Rel-16CT#88-e2020-07-07
15.9.0Rel-15CT#88-e2020-07-07
16.0.0Rel-16CT#87-e2020-03-30
15.8.0Rel-15CT#862020-01-08
15.7.0Rel-15CT#852019-09-26
15.5.1Rel-15CT#822019-04-26
15.6.0Rel-15CT#832019-03-24
14.8.0Rel-14CT#832019-03-24
15.5.0Rel-15CT#822018-12-21
9.12.2Rel-9CT#812018-10-18
9.12.1Rel-9CT#812018-10-17

Atlas classifications

Meaning and provenance

No Atlas classifications have been attached yet.

Work Items

Standards work connected to TS 31.111

MMS4

Multimedia Messaging

Rel-4official
TEI4

(Small) Technical Enhancements and Improvements for Rel-4

Rel-4parsed
USAT1-LocLnk

USAT local link

Rel-4official
WI 10004

Main IETF dependencies

Rel-5official
WI 2524

IETF: RFC 3323 (SIP extensions for caller identity and privacy)

Rel-5official
WI 2522

IETF: RFC 3312 (Without COMET)(Integration of resource management and SIP)

Rel-5official
WI 2523

IETF: RFC 3262 (Reliability of provisional responses)

Rel-5official
WI 2521

IETF: RFC 3261 (Session Initiation Protocol)

Rel-5official
WI 1292

Impact on HSS

Rel-5official
WI 1291

Architectural issues

Rel-5official
WI 1290

Addressing

Rel-5official
WI 11024

IETF: RFC editor Queue (Various 3GPP Private Extensions)

Rel-5official
WI 11023

IETF: RFC 3324 (Network Asserted Identity)

Rel-5official
WI 11022

IETF: RFC 3311 (The Update method)

Rel-5official
WI 11005

IETF: RFC 3266 (IPv6 support within SDP)

Rel-5official
WI 11004

IETF: RFC 3267 (AMR and AMR WB RTP and SDP)

Rel-5official
WI 11002

IETF: RFC editor Queue (DHCP options for SIP servers)

Rel-5official
WI 11001

IETF: RFC editor Queue (refer method)

Rel-5official
WI 11000

IETF: RFC 3265 (specific event notification)

Rel-5official
WI 2525

IETF: RFC 3313 (SIP extensions for media authorization)

Rel-5official
IMS

Provisioning of IP-based multimedia services

Rel-5official
TEI5

(Small) Technical Enhancements and Improvements for Rel-5

Rel-5parsed
UEM

User Equipment Management

Rel-5official
USAT5

Rel-5 USIM toolkit enhancements

Rel-5official
Effective Acronym:

C SIM API

Rel-6official
Effective Acronym:

Stage 3 for Subscriber certificates

Rel-6official
SEC1-SC

Subscriber certificates

Rel-6official
SEC16

Rel-6 Security enhancements

Rel-6official
TEI6

(Small) Technical Enhancements and Improvements for Rel-6

Rel-6parsed
USAT1

Rel-6 UICC/USIM enhancements and interworking

Rel-6official
WLAN

WLAN-UMTS Interworking Rel-6

Rel-6official
NSP

Network selection enhancements (NSP)

Rel-7official
NSP-CR

Procedural aspects of NSP

Rel-7parsed
TEI7

(Small) Technical Enhancements and Improvements for Rel-7

Rel-7parsed
USSD-USIM

Alignment with requirements regarding USSD usage

Rel-7official
FS_SAE

Study on 3GPP System Architecture Evolution

Rel-8official
IWLANNSP

I-WLAN Network Selection Principle (NSP)

Rel-8official
IWLANNSP

CT6 part of Stage 3 for I-WLAN NSP

Rel-8official
SAES

CT6 aspects of SAE

Rel-8official
SAES

3GPP System Architecture Evolution Specification - Evolved Packet System (non RAN aspects)

Rel-8official
SAES

Core specification for CT6 aspects of SAE

Rel-8official
TEI8

(Small) Technical Enhancements and Improvements for Rel-8

Rel-8parsed
TEI9

(Small) Technical Enhancements and Improvements for Rel-9

Rel-9parsed
AT_UICC

AT Commands for USIM Application Toolkit (USAT)

Rel-10parsed
CC_IMS_USIM

Communication Control for IMS by USIM (Stage 3)

Rel-10official
FS_IMS-UICC

Study on UICC access to IMS

Rel-10parsed
IMS-UICC-S

CT6 part of UICC access to IMS Specification

Rel-10official
IMS-UICC-S

UICC access to IMS Specification

Rel-10official
SCWS_L

Introduction of Smart Card Web Server launch functionality

Rel-10parsed
TEI10

(Small) Technical Enhancements and Improvements for Rel-10

Rel-10parsed
USAT_AT

USAT using AT Commands

Rel-10official
HPM_UICC

Definition of the UICC Application for Hosting Party Module

Rel-11parsed
SIMTC-ReachCSPS

CT6 part of Stage 3 BB1: Reachability Aspects of SIMTC

Rel-11official
TEI11

(Small) Technical Enhancements and Improvements for Rel-11

Rel-11parsed
IMS_UApAs

IMS impacts on UICC Application Aspects (Stage 3)

Rel-12official
MTCe-UEPCOP-CT

Stage 3 for BB3: UE Power Consumptions Optimizations (UEPCOP)

Rel-12parsed
MTCe-UEPCOP-CT6

CT6 part of Stage 3 for BB3: UE Power Consumptions Optimizations (UEPCOP)

Rel-12official
TEI12

(Small) Technical Enhancements and Improvements for Rel-12

Rel-12parsed
Red_UCe

Review of dedicated 3GPP UICC features

Rel-13parsed
TEI13

(Small) Technical Enhancements and Improvements for Rel-13

Rel-13parsed
TEI14

(Small) Technical Enhancements and Improvements for Rel-14

Rel-14parsed
5GS_Ph1-CT

CT aspects of 5G System - Phase 1

Historical association · verification pending
Rel-15historical link
TEI16

(Small) Technical Enhancements and Improvements for Rel-16

Rel-16parsed
5GProtoc17

Stage-3 5GS NAS protocol development 17

Historical association · verification pending
Rel-17historical link
5GSAT_ARCH-CT

CT aspects of 5GC architecture for satellite networks

Rel-17parsed
5G_ProSe

Proximity based Services in 5GS

Rel-17parsed
IoT_SAT_ARCH_EPS

Architecture support for NB-IoT/eMTC Non-Terrestrial Networks in EPS

Historical association · verification pending
Rel-17historical link
MINT

Support for Minimization of service Interruption

Historical association · verification pending
Rel-17historical link
NSWO_5G

Non-Seamless WLAN offload in 5GS

Historical association · verification pending
Rel-17historical link
TEI17

(Small) Technical Enhancements and Improvements for Rel-17

Rel-17parsed
eCPSOR_CON

Enhancement for the 5G Control Plane Steering of Roaming for UE in Connected mode

Historical association · verification pending
Rel-17historical link
TEI18

(Small) Technical Enhancements and Improvements for Rel-18

Rel-18parsed
TEI19

(Small) Technical Enhancements and Improvements for Rel-19

Rel-19parsed
MNSCN_UICC-CT

Proactive UICC Command of Mobile Number Status Change Notification

Rel-20parsed
TEI20

(Small) Technical Enhancements and Improvements for Rel-20

Rel-20parsed
SAT

SIM Application Toolkit

R99official
TEI

(Small) Technical Enhancements and Improvements for R99

R99parsed
UICC

UICC / Terminal interface; Physical and logical characteristics

R99official
USAT

USIM Application Toolkit

R99official
USSD

Unstructured Supplementary Service Data (USSD)

R99official

Knowledge graph

Related standards

No graph edges indexed yet. The graph API is available at this JSON endpoint.